Перейти к содержимому


Пустой белый лист


  • Закрытая тема Тема закрыта
Сообщений в теме: 11

#1 LLIbIcpEP

LLIbIcpEP

    Участник

  • Пользователи
  • PipPip
  • 21 сообщений
  • Пол:Мужчина
  • Форум:IPB 2.3.x
  • Версия MKP:C1.2.1

Отправлено 24 February 2008 - 02:11

Ставил на своей машине (чего ставил в профиле указано), все норм работает. Заливаю на хостинг, ставлю форум, все норм. Заливаю портал, установка проходит нормально. Но потом при попытке зайти на сайт index.php - пустой чистый лист! в админку тож не получается! А форум в это время отменно работает=\ Помогите плз!

#2 LLIbIcpEP

LLIbIcpEP

    Участник

  • Пользователи
  • PipPip
  • 21 сообщений
  • Пол:Мужчина
  • Форум:IPB 2.3.x
  • Версия MKP:C1.2.1

Отправлено 24 February 2008 - 02:16

$FORUM_PATH = "forums/";
структура:
forums/
core/
index.php

#3 LLIbIcpEP

LLIbIcpEP

    Участник

  • Пользователи
  • PipPip
  • 21 сообщений
  • Пол:Мужчина
  • Форум:IPB 2.3.x
  • Версия MKP:C1.2.1

Отправлено 24 February 2008 - 02:18

мож дело в Register_globals и Output_buffering? (на сервере оба выключены)

#4 LLIbIcpEP

LLIbIcpEP

    Участник

  • Пользователи
  • PipPip
  • 21 сообщений
  • Пол:Мужчина
  • Форум:IPB 2.3.x
  • Версия MKP:C1.2.1

Отправлено 24 February 2008 - 02:19

сменил, не помогло...

#5 LLIbIcpEP

LLIbIcpEP

    Участник

  • Пользователи
  • PipPip
  • 21 сообщений
  • Пол:Мужчина
  • Форум:IPB 2.3.x
  • Версия MKP:C1.2.1

Отправлено 24 February 2008 - 02:26

Код
<?php

?>

вырезал из этого файла все, всеравно просто белый лист...ни ошибки тебе, ничего, просто белый лист...

#6 LLIbIcpEP

LLIbIcpEP

    Участник

  • Пользователи
  • PipPip
  • 21 сообщений
  • Пол:Мужчина
  • Форум:IPB 2.3.x
  • Версия MKP:C1.2.1

Отправлено 24 February 2008 - 02:29

эммм..не понял разницу.
root - главная папка на хостинге
root/core
root/forums
root/index.php

в core сам портал(тотже conf_mk.php), в forums - форум. На локальной машине та-же самая структура файлов, и все работает!

#7 LLIbIcpEP

LLIbIcpEP

    Участник

  • Пользователи
  • PipPip
  • 21 сообщений
  • Пол:Мужчина
  • Форум:IPB 2.3.x
  • Версия MKP:C1.2.1

Отправлено 24 February 2008 - 02:34

эммм... ;) нууу....яж вроде при установке указал путь к сайту))
А можно гденить исправить mkportal на core так шоб все работало?)
зы: проверил, работает, большое СПАСИБО!

#8 LLIbIcpEP

LLIbIcpEP

    Участник

  • Пользователи
  • PipPip
  • 21 сообщений
  • Пол:Мужчина
  • Форум:IPB 2.3.x
  • Версия MKP:C1.2.1

Отправлено 24 February 2008 - 02:45

мдя...луче я с mkportal посижу))) так проще, и все работает))

#9 LLIbIcpEP

LLIbIcpEP

    Участник

  • Пользователи
  • PipPip
  • 21 сообщений
  • Пол:Мужчина
  • Форум:IPB 2.3.x
  • Версия MKP:C1.2.1

Отправлено 24 February 2008 - 02:54

ого! спс канешн, но не надо было так париться!)))

#10 LLIbIcpEP

LLIbIcpEP

    Участник

  • Пользователи
  • PipPip
  • 21 сообщений
  • Пол:Мужчина
  • Форум:IPB 2.3.x
  • Версия MKP:C1.2.1

Отправлено 24 February 2008 - 03:25

Код
Warning: require(./mkportal/include/class_mkportals.php) [function.require]: failed to open stream: No such file or directory in C:\AppServ\www\mkportal\core\include\IPB\ipb_driverf.php on line 99


Не, там намного больше файлов перепалачивать придется кажись)))

#11 DNP

DNP

    Активный участник

  • Администраторы
  • PipPipPip
  • 2561 сообщений
  • Пол:Мужчина
  • Город:RUS
  • Форум:IPB 3.2, IPB 3.1
  • Версия MKP:R1.0.2, R1.0.1

Отправлено 24 February 2008 - 11:08

Угу всю систему все функции придётся переделывать да и вдальнейшем проблемы сторонними модами и тд грубо говоря не реально простому юзеру зделать это! чем не устраивает каталог mkportal?

#12 LLIbIcpEP

LLIbIcpEP

    Участник

  • Пользователи
  • PipPip
  • 21 сообщений
  • Пол:Мужчина
  • Форум:IPB 2.3.x
  • Версия MKP:C1.2.1

Отправлено 24 February 2008 - 14:11

Да уж, тему офф) хотел сделать красиво)




Количество пользователей, читающих эту тему: 1

0 пользователей, 1 гостей, 0 анонимных